Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Applicable Applications

  • Cloud (only up to version 2.3.12)
  • Wrapper (only up to version 2.3.12)
  • Downloader (only up to version 1.2.1)

Stacktrace

Code Block
languagejava
linenumberstrue
Exception in thread "main" java.lang.NoSuchFieldException: modifiers
at java.base/java.lang.Class.getDeclaredField(Class.java:2412)

Meaning

You are using a newer version of Java than supported. Up until the versions listed in the applicable applications section, CaveCloud only supports official Oracle Java 1.8.

How to fix

...

Recommended: Update your CaveCloud application to the latest version in order to run it with a newer Java version.

Alternatively you can downgrade your Java Version to Oracle 1.8.x